Resolved
The fix has been successfully tested and implemented. Please contact Support if you have any questions.
Identified
A fix has been identified and is currently being tested.
Investigating
If you feel you are experiencing an issue with your Google Ads / Google Customer Match, please submit a Support ticket.