Ongoing AWS Incident Impacting Ad Hoc Queries
Incident Report for Amperity
Resolved
While the AWS incident is still not marked closed, the impacts on Amperity seem to have been mitigated and we are declaring this incident resolved.
Posted Sep 18, 2023 - 22:46 PDT
Update
Amazon Web Services continues to work towards resolving the issues that are impacting queries on the Amperity platform. Positive improvements have been noted but their issues are not yet fully resolved, so we will keep this incident open until we are confident that things have returned to normal. Our Platform Engineering team continues to monitor their status.
Posted Sep 18, 2023 - 21:44 PDT
Update
Amazon Web Services is continuing to take steps to address resource contention within the AWS subsystems that are impacting queries in Amperity. Our Platform Engineering team is continuing to monitor the situation.
Posted Sep 18, 2023 - 18:20 PDT
Update
Amazon Web Services has taken steps to address resource contention within the AWS subsystems that are impacting queries in Amperity. Our Platform Engineering team is monitoring the situation and is beginning to see some signs of improvement.
Posted Sep 18, 2023 - 15:52 PDT
Monitoring
An ongoing incident within Amazon Web Services is impacting ad-hoc queries running within the Amperity platform for our AWS customers. Queries that are part of scheduled workflows will be automatically retried, but users issuing ad-hoc queries may encounter failures. Those failures are transient and frequently succeed upon retry.

The Amperity Platform Engineering team is monitoring the AWS incident and we will continue to provide updates here as we learn more.
Posted Sep 18, 2023 - 13:06 PDT
This incident affected: Platforms (AWS Platform) and Application (Segments).