Amperity is experiencing performance issues in AWS with the query service

Incident Report for Amperity

Resolved

AWS has confirmed that the issue is resolved. Amperity monitored and restarted all the failed workflows and has confirmed that this incident is resolved.
Posted Jun 13, 2025 - 13:31 PDT

Monitoring

The issue is due to performance issues in the underlying AWS platform. AWS has identified the problem and are on the path to recovery. Amperity is continuing to monitor the AWS resolution actions.
Posted Jun 13, 2025 - 10:42 PDT

Investigating

The query service of the Amperity platform in AWS are experiencing performance issues. We're working on the problem and expect it to be resolved shortly.
Posted Jun 13, 2025 - 09:57 PDT
This incident affected: Platforms (AWS Platform) and Application (Segments, Workflows).